HornWare.com Forum Index HornWare.com
HornWare.com Help Forum
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

User permissions issue connecting to SMB from Win XP client

 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    HornWare.com Forum Index -> SharePoints
View previous topic :: View next topic  
Author Message
abro



Joined: 27 Dec 2007
Posts: 1

PostPosted: Thu Dec 27, 2007 5:51 pm    Post subject: User permissions issue connecting to SMB from Win XP client Reply with quote

I'm sure this is classic newby stuff, but I've checked the forums for the obvious solutions to no avail.

Basically, I have two users on my Mac, one is me with root and the other is my wife who is in the Staff group. (I have also tried adding her to the Admin group as a sanity test, but that failed too).

I have enabled Windows sharing in the Preferences app and enabled both of our accounts in the Preferences>Sharing> Accounts option.

When I login to the SMB share as me over the network from my wife's Win XP laptop, everything works perfectly. When I login as her, it fails. I've tested her password by logging in to my Mac with it, so I think I have the basic data entry squared away.

I've established that SMB access to the share is permitted by using my login to connect from the Win XP machine. I've also established that the XP machine in general can communicate via the network with my Mac. I've duplicated the failed experiment on the XP guest OS on my Mac, which supports my suspicion that it is a user permission issue.

In an effort to simplify further, I enabled via Sharepoint full R/W permissions on the share, and added my wife to the Admin group, but still no luck. I've also tried changing the owner via Sharepoint to my wife's login with no luck.

Somehow the solution eludes me. Does anyone have any advice for me?

Please advise.

TIA,
Adam
Back to top
View user's profile Send private message
mhorn
Site Admin


Joined: 10 Jul 2003
Posts: 599

PostPosted: Mon Dec 31, 2007 10:41 am    Post subject: Reply with quote

This sounds to me like you need to enable your wife in Preferences>Sharing> Accounts. However, you have already done that. I'm at a loss.
Back to top
View user's profile Send private message Send e-mail Visit poster's website
alexmd



Joined: 03 Jan 2008
Posts: 2
Location: Denver, CO

PostPosted: Thu Jan 03, 2008 10:43 pm    Post subject: Reply with quote

The permissions issues are very tricky, even from one Windows machine to another. I've not used XP but from W2K you can, from Network control panel or right click on Network icon on desktop, select Map Network Drive, then Log on as different User, and put in the user ID and pwd of the native owner of the shared drive or folder you are trying to connect to.

In your case, perhaps have wife do above and put in your user ID and pwd when trying to connect from the XP machine (logged into Windows as herself tho). If that still doesn't work, you might have to do major jiggling of permissions on the Mac -- put shared files in a Public folder or something.
Back to top
View user's profile Send private message
Display posts from previous:   
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    HornWare.com Forum Index -> SharePoints All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group